JohnRouda.com presents:

Microsoft® Office Excel® 2007 Training

Create a chart
Course contents

- Overview: Charts make data visual
- Lesson 1: Create a basic chart
- Lesson 2: Customize your chart

Each lesson includes a list of suggested tasks and a set of test questions.
Overview: Charts make data visual

A chart gets your point across—fast. With a chart, you can transform worksheet data to show comparisons, patterns, and trends.

So instead of having to analyze columns of worksheet numbers, you can see at a glance what the data means.

This course presents the basics of creating charts in Excel 2007.
Course goals

• Learn how to create a chart using the new Excel 2007 commands.

• Find out how to make changes to a chart after you create it.

• Develop an understanding of basic chart terminology.
Lesson 1

Create a basic chart
Create a basic chart

Here’s a basic chart in Excel, which you can put together in about 10 seconds.

After you create a chart, you can easily add new elements to it such as chart titles or a new layout.

In this lesson you’ll find out how to create a basic chart and learn how the text and numbers from a worksheet become the contents of a chart. You’ll also learn a few other chart odds and ends.
Create your chart

Here's a worksheet that shows how many cases of Northwind Traders Tea were sold by each of three salespeople in three months.

You want to create a chart that shows how each salesperson compares against the others, month by month, for the first quarter of the year.
Create your chart

1. Select the data that you want to chart, including the column titles (January, February, March) and the row labels (the salesperson names).

2. Click the **Insert** tab, and in the **Charts** group, click the **Column** button.
Create your chart

The picture shows the steps for creating the chart.

3 You’ll see a number of column chart types to choose from. Click **Clustered Column**, the first column chart in the **2-D Column** list.

That’s it. You’ve created a chart in about 10 seconds.
Create your chart

If you want to change the chart type after creating your chart, click inside the chart.

On the **Design** tab under **Chart Tools**, in the **Type** group, click **Change Chart Type**. Then select the chart type you want.
How worksheet data appears in the chart

Here's how your new column chart looks.

It shows you at once that Cencini (represented by the middle column for each month) sold the most tea in January and February but was outdone by Giussani in March.
How worksheet data appears in the chart

Data for each salesperson appears in three separate columns, one for each month.

<table>
<thead>
<tr>
<th></th>
<th>January</th>
<th>February</th>
<th>March</th>
</tr>
</thead>
<tbody>
<tr>
<td>Giussani</td>
<td>70</td>
<td>160</td>
<td>300</td>
</tr>
<tr>
<td>Cencini</td>
<td>175</td>
<td>420</td>
<td>290</td>
</tr>
<tr>
<td>Kotas</td>
<td>150</td>
<td>180</td>
<td>195</td>
</tr>
</tbody>
</table>

The height of each chart is proportional to the value in the cell that it represents.

So the chart immediately shows you how the salespeople stack up against each other, month by month.
How worksheet data appears in the chart

Each row of salesperson data has a different color in the chart.

The chart legend, created from the row titles in the worksheet (the salesperson names), tells which color represents the data for each salesperson.

Giussani data, for example, is the darkest blue, and is the left-most column for each month.
How worksheet data appears in the chart

The column titles from the worksheet—January, February, and March—are now at the bottom of the chart.

On the left side of the chart, Excel has created a scale of numbers to help you to interpret the column heights.
Chart Tools: Now you see them, now you don’t

Before you do more work with your chart, you need to know about the Chart Tools.

After your chart is inserted on the worksheet, the Chart Tools appear on the Ribbon with three tabs: Design, Layout, and Format.

On these tabs, you’ll find the commands you need to work with charts.
Chart Tools: Now you see them, now you don’t

When you complete the chart, click outside it. The Chart Tools go away.

To get them back, click inside the chart. Then the tabs reappear.

So don’t worry if you don’t see all the commands you need at all times.

Take the first steps either by inserting a chart (using the Charts group on the Insert tab), or by clicking inside an existing chart. The commands you need will be at hand.
Change the chart view

You can do more with your data than create one chart.

You can make your chart compare data another way by clicking a button to switch from one chart view to another.

The picture shows two different views of the same worksheet data.
Change the chart view

The chart on the left is the chart you first created, which compares salespeople to each other.

Excel grouped data by worksheet columns and compared worksheet rows to show how each salesperson compares against the others.
But another way to look at the data is to compare sales for each salesperson, month over month.

To create this view of the chart, click **Switch Row/Column** in the **Data** group on the **Design** tab.

In the chart on the right, data is grouped by rows and compares worksheet columns. So now your chart says something different: It shows how each salesperson did, month by month, compared against themselves.
Add chart titles

It’s a good idea to add descriptive titles to your chart, so that readers don’t have to guess what the chart is about.

You can give a title to the chart itself, as well as to the chart axes, which measure and describe the chart data.

This chart has two axes. On the left side is the vertical axis, which is the scale of numbers by which you can interpret the column heights. The months of the year at the bottom are on the horizontal axis.
Add chart titles

A quick way to add chart titles is to click the chart to select it, and then go to the Charts Layout group on the Design tab.

Click the More button to see all the layouts. Each option shows different layouts that change the way chart elements are laid out.
Add chart titles

The picture shows Layout 9, which adds placeholders for a chart title and axes titles.

You type the titles directly in the chart.

1. The title for this chart is **Northwind Traders Tea**, the name of the product.
2. The title for the vertical axis on the left is **Cases Sold**.
3. The title for the horizontal axis at the bottom is **First Quarter Sales**.
Suggestions for practice

1. Create a chart.

2. Look at chart data in different ways.

3. Update chart data.

4. Add titles.

5. Change chart layouts.

6. Change the chart type.

[Online practice](#) (requires Excel 2007)
Test 1, question 1

You’ve created a chart. Now you need to compare data another way. To do this, you must create a second chart. (Pick one answer.)

1. True.
2. False.
False.

You can quickly create another view of your worksheet data by clicking the **Switch Row/Column** button on the **Design** tab.
You create a chart. But later on you don’t see the Chart Tools. What do you do to get them back? (Pick one answer.)

1. Create another chart.
2. Click the **Insert** tab.
3. Click inside the chart.
Click inside the chart.

The **Chart Tools** will then be at hand with three tabs: **Design**, **Layout**, and **Format**.
Test 1, question 3

You can’t change the chart type after you create a chart. (Pick one answer.)

1. True.
2. False.
False.

You can always change the chart type after you create your chart. Click inside the chart. On the **Design** tab, in the **Type** group, Click **Change Chart Type**, and then select another chart type.
Lesson 2

Customize your chart
Create a chart

Customize your chart

After you create your chart, you can customize it to give it a more professional design.

For example, you can give your chart a whole different set of colors by selecting a new chart style.

You can also format chart titles to change them from plain to fancy. And there are many different formatting options you can apply to individual columns to make them stand out.
Create a chart

When you first create your chart, it’s in a standard color.

By using a **chart style**, you can apply different colors to a chart in just seconds.

First, click in the chart. Then on the **Design** tab, in the **Chart Styles** group, click the **More** button to see all the choices.

Then click the style you want.
Change the look of your chart

When you first create your chart, it’s in a standard color.

By using a chart style, you can apply different colors to a chart in just seconds.

Some of the styles change just the color of the columns.

Others change the color and add an outline around the columns, while other styles add color to the plot area (the area bounded by the chart axes). And some styles add color to the chart area (the entire chart).
Change the look of your chart

If you don’t see what you want in the Chart Styles group, you can get other color choices by selecting a different theme.

Click the Page Layout tab, and then click Colors in the Themes group.

When you rest the pointer over a color scheme, the colors are shown in a temporary preview on the chart. Click the one you like to apply it to the chart.
Change the look of your chart

Important

Unlike a chart style, the colors from a theme will be applied to other elements you might add to the worksheet.

For example, a table or a cell style such as a heading will take on the colors of the theme applied to the chart.
If you’d like to make the chart or axis titles stand out more, that’s also easy to do.

On the **Format** tab, in the **WordArt Styles** group, there are many ways to work with the titles.

The picture shows that one of the options in the group, a text fill, has been added to change the color.
To use a **text fill**, first click in a title area to select it.

Then click the arrow on **Text Fill** in the **WordArt Styles** group. Rest the pointer over any of the colors to see the changes in the title. When you see a color you like, select it.

**Text Fill** also includes options to apply a gradient or a texture to a title.
Format titles

To make font changes, such as making the font larger or smaller—or to change the font face—click Home, and then go to the Font group.

Or you can make the same formatting changes by using the **Mini toolbar**.

The toolbar appears in a faded fashion after you select the title text. Point at the toolbar and it becomes solid, and then you can select a formatting option.
Format individual columns

There is still more that you can do with the format of the columns in your chart.

In the picture, a shadow effect has been added to each of the columns (an offset diagonal shadow is behind each column).
Format individual columns

Here's how to add a shadow effect to columns.

1. Click one of Giussani’s columns. That will select all three columns for Giussani (known as a series).

2. On the Format tab, in the Shape Styles group, click the arrow on Shape Effects.
3. Point to **Shadow**, and then rest the pointer on the different shadow styles in the list.

4. You can see a preview of the shadows as you rest the pointer on each style. When you see one you like, select it.
The **Shape Styles** group offers plenty of other great formatting options to choose from.

For example, **Shape Effects** offers more than just shadows. You can add bevel effects and soft edges to columns, or even make columns glow.

You can also click **Shape Fill** to add a gradient or a texture to the columns, or click **Shape Outline** to add an outline around the columns.
Add your chart to a PowerPoint presentation

When your chart looks just the way you want and it’s ready for a debut, you can easily add it to a Microsoft Office PowerPoint® presentation.

Here’s how it works.

1. Copy the chart in Excel.
3. On the slide you want the chart to be on, paste the chart.
Add your chart to a PowerPoint presentation

When your chart looks just the way you want and it’s ready for a debut, you can easily add it to a Microsoft Office PowerPoint® presentation.

Here’s how it works.

4. In the chart’s lower-right corner, the Paste Options button appears. Click the button.

Now you’re ready to present your chart.
Suggestions for practice

1. Change the look of a chart.
2. Try out a color scheme by using a theme.
3. Format the chart title.
4. Format a column.
5. Format other areas of the chart.
6. Add your chart to a PowerPoint presentation.
7. Bonus exercises: Make a pie chart, and save your chart as a template.

Online practice (requires Excel 2007)
Test 2, question 1

If you don’t see all the color options you want for your chart in the Chart Styles group on the Design tab, you have another way to get more colors. (Pick one answer.)

1. True.

2. False.
You can pick other colors by selecting a theme. Click the **Page Layout** tab, and then click **Colors** in the **Themes** group. Remember that the colors from the themes will be applied to other elements in the worksheet such as a table or cell styles.
What do you do first to add an Excel chart to a PowerPoint 2007 presentation? (Pick one answer.)

1. Click the Data tab.
2. Click the Insert tab.
3. Copy the chart.
Test 2, question 2: Answer

Copy the chart.

Then open PowerPoint 2007, paste, and it’s done.
Quick Reference Card

For a summary of the tasks covered in this course, view the Quick Reference Card.
JohnRouda.com presents:

Microsoft® Office Excel® 2007 Training

Create your first workbook
Course contents

• Overview: Where to begin?

• Lesson 1: Meet the workbook

• Lesson 2: Enter data

• Lesson 3: Edit data and revise worksheets

Each lesson includes a list of suggested tasks and a set of test questions.
Overview: Where to begin?

You’ve been asked to enter data in Excel 2007, but you’ve never worked with Excel. Where do you begin?

Or perhaps you have worked in Excel but still wonder how to do some of the basics like entering and editing text and numbers, or adding and deleting columns and rows.

Here you’ll learn the skills you need to work in Excel, quickly and with little fuss.
Course goals

- Create a new workbook.
- Enter text and numbers.
- Edit text and numbers.
- Insert and delete columns and rows.
Lesson 1

Meet the workbook
Meet the workbook

When you start Excel, you’re faced with a big empty grid made up of columns, rows, and cells.

If you’re new to Excel, you may wonder what to do next.

So this course will start by helping you get comfortable with some Excel basics that will guide you when you enter data in Excel.
The band at the top of the Excel 2007 window is called the **Ribbon**.

The Ribbon is made up of different **tabs**, each of which is related to specific kinds of work that people do in Excel.

You click the tabs at the top of the Ribbon to see the different commands on each tab.
The Ribbon spans the top of the Excel window.

Commands on the Ribbon are organized in small related groups. For example, commands to work with the contents of cells are grouped together in the Editing group, and commands to work with cells themselves are in the Cells group.
When you start Excel, you open a file that’s called a **workbook**.

Each new workbook comes with three **worksheets** into which you enter data.

Shown here is a blank worksheet in a new workbook.

1. The first workbook you’ll open is called Book1. This title appears in the bar at the top of the window until you save the workbook with your own title.
When you start Excel, you open a file that’s called a **workbook**.

Each new workbook comes with three **worksheets** into which you enter data.

Shown here is a blank worksheet in a new workbook.

Sheet tabs appear at the bottom of the window. It’s a good idea to rename the sheet tabs to make the information on each sheet easier to identify.
Create your first workbook

Workbooks and worksheets

1. Click the **Microsoft Office Button** in the upper-left portion of the window.

2. Click **New**.

3. In the **New Workbook** window, click **Blank Workbook**.
Columns, rows, and cells

Worksheets are divided into columns, rows, and cells.

That’s the grid you see when you open up a workbook.

1. Columns go from top to bottom on the worksheet, vertically. Each column has an alphabetical heading at the top.

2. Rows go across the worksheet, horizontally. Each row also has a heading. Row headings are numbers, from 1 through 1,048,576.

Create your first workbook
Columns, rows, and cells

Worksheets are divided into columns, rows, and cells.

That’s the grid you see when you open up a workbook.

The alphabetical headings on the columns and the numerical headings on the rows tell you where you are in a worksheet when you click a cell.

The headings combine to form the cell address. For example, the cell at the intersection of column A and row 3 is called cell A3. This is also called the cell reference.
Cells are where the data goes. Cells are where you get down to business and enter data in a worksheet.

The picture on the left shows what you see when you open a new workbook.

The first cell in the upper-left corner of the worksheet is the **active cell**. It’s outlined in black, indicating that any data you enter will go there.
Cells are where the data goes

You can enter data wherever you like by clicking any cell in the worksheet to select the cell.

When you select any cell, it becomes the active cell. As described earlier, it becomes outlined in black.

The headings for the column and row in which the cell is located are also highlighted.
Cells are where the data goes

You can enter data wherever you like by clicking any cell in the worksheet to select the cell.

For example, if you select a cell in column C on row 5, as shown in the picture on the right:

1. Column C is highlighted.
2. Row 5 is highlighted.
You can enter data wherever you like by clicking any cell in the worksheet to select the cell.

For example, if you select a cell in column C on row 5, as shown in the picture on the right:

3. The active cell, C5 in this case, is outlined. And its name—also known as the **cell reference**—is shown in the Name Box in the upper-left corner of the worksheet.
Cells are where the data goes

The outlined cell, highlighted column and row headings, and appearance of the cell reference in the Name Box make it easy for you to see that C5 is the active cell.

These indicators aren’t too important when you’re right at the top of the worksheet in the very first few cells.

But when you work farther and farther down or across the worksheet, they can really help you out.
Suggestions for practice

1. Rename a worksheet tab.
2. Move from one worksheet to another.
3. Add color to worksheet tabs.
4. Add and delete worksheets.
5. Review column headings and use the Name Box.

Online practice (requires Excel 2007)
You need a new workbook. How do you create one? (Pick one answer.)

1. In the **Cells** group, click **Insert**, and then click **Insert Sheet**.

2. Click the **Microsoft Office Button**, and then click **New**. In the **New Workbook** window, click **Blank workbook**.

3. In the **Cells** group, click **Insert**, and then click **Workbook**.

---

Create your first workbook
Click the **Microsoft Office Button**, and then click **New**. In the **New Workbook** window, click **Blank workbook**.
The Name Box shows the contents of the active cell. (Pick one answer.)

1. True.
2. False.
False.

The Name Box gives you the cell reference of the active cell. You can also use the Name Box to select a cell, by typing that cell reference in the box.
Test 1, question 3

In a new worksheet, you must start by typing in cell A1. (Pick one answer.)

1. True.
2. False.
False.

You’re free to roam and type wherever you want. Click in any cell and start to type. But don’t make readers scroll to see data that could just as well start in cell A1 or A2.
Lesson 2

Enter data
You can use Excel to enter all sorts of data, professional or personal.

You can enter two basic kinds of data into worksheet cells: numbers and text.

So you can use Excel to create budgets, work with taxes, record student grades or attendance, or list the products you sell. You can even log daily exercise, follow your weight loss, or track the cost of your house remodel. The possibilities really are endless.

Now let’s dive into data entry.
Be kind to your readers: start with column titles

When you enter data, it’s a good idea to start by entering titles at the top of each column.

This way, anyone who shares your worksheet can understand what the data means (and you can understand it yourself, later on).

You’ll often want to enter row titles too.
Be kind to your readers: start with column titles

The worksheet in the picture shows whether or not representatives from particular companies attended a series of monthly business lunches.

It uses column and row titles:

1. The column titles are the months of the year, across the top of the worksheet.
2. The row titles down the left side are company names.
Start typing

Say you’re creating a list of salespeople names.

The list will also have the dates of sales, with their amounts.

So you’ll need these column titles: **Name**, **Date**, and **Amount**.
Say you’re creating a list of salespeople names.

The list will also have the dates of sales, with their amounts.

The picture illustrates the process of typing the information and moving from cell to cell:

1. Type **Name** in cell A1 and press TAB. Then type **Date** in cell B1, press TAB, and type **Amount** in cell C1.
Create your first workbook

Start typing

Say you’re creating a list of salespeople names.

The list will also have the dates of sales, with their amounts.

The picture illustrates the process of typing the information and moving from cell to cell:

2. After typing the column titles, click in cell A2 to begin typing the salespeople’s names. Type the first name, and then press ENTER to move the selection down the column by one cell to cell A3. Then type the next name, and so on.
Excel aligns text on the left side of cells, but it aligns dates on the right side of cells.

To enter a date in column B, the **Date** column, you should use a slash or a hyphen to separate the parts: 7/16/2009 or 16-July-2009. Excel will recognize either as a date.
Enter dates and times

Excel aligns text on the left side of cells, but it aligns dates on the right side of cells.

If you need to enter a time, type the numbers, a space, and then a or p—for example, 9:00 p. If you put in just the number, Excel recognizes a time and enters it as AM.
Enter numbers

Excel aligns numbers on the right side of cells.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Name</td>
<td>Date</td>
</tr>
<tr>
<td>2</td>
<td>Buchanan</td>
<td>7/16/2009</td>
</tr>
<tr>
<td>3</td>
<td>Suyama</td>
<td>7/10/2009</td>
</tr>
<tr>
<td>4</td>
<td>Peacock</td>
<td>7/12/2009</td>
</tr>
</tbody>
</table>

To enter the sales amounts in column C, the **Amount** column, you would type the dollar sign ($), followed by the amount.
Enter numbers

Other numbers and how to enter them

• To enter fractions, leave a space between the whole number and the fraction. For example, 1 1/8.

• To enter a fraction only, enter a zero first, for example, 0 1/4. If you enter 1/4 without the zero, Excel will interpret the number as a date, January 4.

• If you type (100) to indicate a negative number by parentheses, Excel will display the number as -100.
Quick ways to enter data

Here are two time-savers you can use to enter data in Excel: **AutoComplete** and **AutoFill**.

**AutoComplete:** Type a few letters in a cell, and Excel can fill in the remaining characters for you.

**AutoFill:** Type one or more entries in an intended series, and then extend the series. Play the animation to see AutoFill in action.

Animation: Right-click, and click **Play**.
Quick ways to enter data

Here are two time-savers you can use to enter data in Excel: **AutoComplete** and **AutoFill**.

**AutoComplete**: Type a few letters in a cell, and Excel can fill in the remaining characters for you. Just press ENTER when you see them added.

**AutoFill**: Type one or more entries in an intended series, and then extend the series.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>January</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>February</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>March</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>April</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>May</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>June</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>July</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>August</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>September</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>October</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>November</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>December</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Suggestions for practice

1. Enter data using TAB and ENTER.
2. Fix mistakes as you type.
3. Enter dates and times.
4. Enter numbers.
5. Use AutoFill.
6. Use AutoComplete.

Online practice (requires Excel 2007)
Test 2, question 1

Pressing ENTER moves the selection one cell to the right. (Pick one answer.)

1. True.
2. False.
Test 2, question 1: Answer

False.

Pressing ENTER moves the selection down. Pressing TAB moves the selection to the right.
Test 2, question 2

To enter the months of the year without typing each month yourself, you’d use which of the following? (Pick one answer.)

1. AutoComplete.
2. AutoFill.
3. CTRL+ENTER.
AutoFill.

Use AutoFill to complete lists that you’ve begun, such as days, weeks, or times tables.
Test 2, question 3

Which of these will Excel recognize as a date? (Pick one answer.)

1. February 6 1947.
2. 2,6,47.
3. 2-Feb-47.
Test 2, question 3: Answer

2-Feb-47.

You use a slash or a hyphen to separate the parts of a date.
Lesson 3

Edit data and revise worksheets
Everyone makes mistakes. Even data that you entered correctly can need updates later on.

Sometimes, the whole worksheet needs a change.

Suppose you need to add another column of data, right in the middle of your worksheet. Or suppose you list employees one per row, in alphabetical order—what do you do when you hire somebody new?

This lesson shows you how easy it is to edit data and add and delete worksheet columns and rows.
Say that you meant to enter Peacock’s name in cell A2, but you entered Buchanan’s name by mistake.

Once you spot the error, there are two ways to correct it.

1. Double-click a cell to edit the data in it.
2. Or, after clicking in the cell, edit the data in the Formula Bar.
3. After you select the cell by either method, the worksheet says **Edit** in the status bar in the lower-left corner.
Edit data

What’s the difference between the two methods?

Your convenience. You may find the Formula Bar, or the cell itself, easier to work with.

Here’s how you can make changes in either place:

• Delete letters or numbers by pressing BACKSPACE or by selecting them and then pressing DELETE.

• Edit letters or numbers by selecting them and then typing something different.
Edit data

Here’s how you can make changes in either place:

- Insert new letters or numbers into the cell’s data by positioning the cursor and typing.

What’s the difference between the two methods?

Your convenience. You may find the Formula Bar, or the cell itself, easier to work with.
Edit data

What’s the difference between the two methods?
Your convenience. You may find the Formula Bar, or the cell itself, easier to work with.

Whatever you do, when you’re all through, remember to press ENTER or TAB so that your changes stay in the cell.
Remove data formatting

Surprise! Someone else has used your worksheet, filled in some data, and made the number in cell C6 bold and red to highlight that Peacock made the highest sale.

But Peacock’s customer has changed her number, so the final sale was much smaller.

You want to remedy the situation.
Remove data formatting

Surprise! Someone else has used your worksheet, filled in some data, and made the number in cell C6 bold and red to highlight that Peacock made the highest sale.

As the picture shows:

1. The original number was formatted bold and red.
2. So you delete the number.
3. You enter a new number. But it’s still bold and red! What gives?
What’s going on is that the cell itself is formatted, not data in the cell.

So when you delete data that has special formatting, you also need to delete the formatting from the cell.

Until you do, any data you enter in that cell will have special formatting.
Remove data formatting

1. Click in the cell, and then on the Home tab, in the Editing group, click the arrow on Clear.

2. Click Clear Formats, which removes the format from the cell. Or you can click Clear All to remove both the data and the formatting at the same time.
Insert a column or row

After entering data, you may find that you need to add columns or rows to hold additional information.

Do you need to start over? Of course not.

To insert a single column:

1. Click any cell in the column immediately to the right of where you want the new column to go.

2. On the **Home** tab, in the **Cells** group, click the arrow on **Insert**. On the drop-down menu, click **Insert Sheet Columns**. A new blank column is inserted.
Insert a column or row

After entering data, you may find that you need to add columns or rows to hold additional information. Do you need to start over? Of course not.

To insert a single row:

1. Click any cell in the row immediately below where you want the new row.

2. In the **Cells** group, click the arrow on **Insert**. On the drop-down menu, click **Insert Sheet Rows**. A new blank row is inserted.
Insert a column or row

Excel gives a new column or row the heading its place requires, and changes the headings of later columns and rows.

Animation: Right-click, and click Play.

Play the animation to see the process of inserting a column and a row in a worksheet.
Insert a column or row

After entering data, you may find that you need to add columns or rows to hold additional information.

Do you need to start over? Of course not.

Excel gives a new column or row the heading its place requires, and changes the headings of later columns and rows.
Suggestions for practice

1. Edit data.
2. Delete formatting from a cell.
3. Work in Edit mode.
4. Insert and delete columns and rows.

Online practice (requires Excel 2007)
Test 3, question 1

What do you first do to delete the formatting in a cell? (Pick one answer.)

1. Delete the cell contents.
2. Click **Format** in the **Cells** group on the **Home** tab.
3. Click **Clear** in the **Editing** group on the **Home** tab.
Click **Clear** in the **Editing** group on the **Home** tab.

Then click **Clear Formats**.
Test 3, question 2

To add a column, click a cell in the column to the right of where you want the new column. (Pick one answer.)

1. True.

2. False.
Test 3, question 2: Answer

True.

Then on the **Home** tab, in the **Cells** group, click the arrow on **Insert**, and click **Insert Sheet Columns** to insert the column.
To add a new row, click in a cell immediately above where you want the new row. (Pick one answer.)

1. True.
2. False.
Test 3, question 3: Answer

False.

Instead, you click any cell in the row immediately below where you want the new row.
Quick Reference Card

For a summary of the tasks covered in this course, view the Quick Reference Card.
JohnRouda.com presents:

Microsoft® Office
Excel® 2007 Training

Enter formulas
Course contents

• Overview: Goodbye, calculator
• Lesson 1: Get started
• Lesson 2: Use cell references
• Lesson 3: Simplify formulas by using functions

Each lesson includes a list of suggested tasks and a set of test questions.
Overview: Goodbye, calculator

Excel is great for working with numbers and math. In this course you’ll learn how add, divide, multiply, and subtract by typing formulas into Excel worksheets.

You’ll also learn how to use simple formulas that automatically update their results when values change.

After picking up the techniques in this course, you’ll be able to put your calculator away for good.
Course goals

• Do math by typing simple formulas to add, divide, multiply, and subtract.

• Use cell references in formulas, so that Excel can automatically update results when values change or when you copy formulas.

• Use functions (prewritten formulas) to add up values, calculate averages, and find the smallest or largest value in a range of values.
Lesson 1

Get started
Imagine that Excel is open and you’re looking at the “Entertainment” section of a household expense budget.

Cell C6 in the worksheet is empty; the amount spent for CDs in February hasn’t been entered yet.

In this lesson, you’ll learn how to use Excel to do basic math by typing simple formulas into cells. You’ll also learn how to total all the values in a column with a formula that updates its result if values change later.
Begin with an equal sign

The two CDs purchased in February cost $12.99 and $16.99.

The total of these two values is the CD expense for the month.

You can add these values in Excel by typing a simple formula into cell C6.
Begin with an equal sign

Type a formula in cell C6. Excel formulas always begin with an equal sign. To add 12.99 and 16.99, type:

\[=12.99+16.99\]

The plus sign (+) is the math operator that tells Excel to add the values.
Begin with an equal sign

The picture illustrates what to do.

2. Press ENTER to display the formula result.

3. If you wonder later how you got this result, you can click in cell C6 any time and view the formula in the formula bar near the top of the worksheet.
To do more than add, use other math operators as you type formulas into worksheet cells.

Excel uses familiar signs to build formulas.

<table>
<thead>
<tr>
<th>Math operators</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Add (+)</td>
<td>=10+5</td>
</tr>
<tr>
<td>Subtract (-)</td>
<td>=10-5</td>
</tr>
<tr>
<td>Multiply (*)</td>
<td>=10*5</td>
</tr>
<tr>
<td>Divide (/)</td>
<td>=10/5</td>
</tr>
</tbody>
</table>

As the table shows, use a minus sign (-) to subtract, an asterisk (*) to multiply, and a forward slash (/) to divide.

Remember to always start each formula with an equal sign.
Total all the values in a column

To add up the total of expenses for January, you don’t have to type all those values again.

Instead, you can use a prewritten formula called a function.

To get the January total, click in cell B7 and then:

1. On the Home tab, click the Sum button Σ in the Editing group.
2. A color marquee surrounds the cells in the formula, and the formula appears in cell B7.
Total all the values in a column

To add up the total of expenses for January, you don’t have to type all those values again. Instead, you can use a prewritten formula called a **function**.

To get the January total, click in cell B7 and then:

3. Press ENTER to display the result in cell B7: **95.94**.

4. Click in cell B7 to display the formula **=SUM(B3:B6)** in the formula bar.
Total all the values in a column

B3:B6 is the information, called the **argument**, that tells the SUM function what to add.

By using a cell reference (B3:B6) instead of the values in those cells, Excel can automatically update results if values change later on.

The colon (:) in B3:B6 indicates a cell range in column B, rows 3 through 6. The parentheses are required to separate the argument from the function.
Sometimes it's easier to copy formulas than to create new ones.

In this section, you'll see how to copy the formula you used to get the January total and use it to add up February's expenses.
Copy a formula instead of creating a new one

First, select cell B7.

Then position the mouse pointer over the lower-right corner of the cell until the black cross (++) appears.

Next, as the picture shows:

1. Drag the fill handle from cell B7 to cell C7, and release the fill handle. The February total 126.93 appears in cell C7.

The formula =SUM(C3:C6) will also become visible in the formula bar near the top of the worksheet.
Copy a formula instead of creating a new one

First, select cell B7.

Then position the mouse pointer over the lower-right corner of the cell until the black cross (+) appears.

Next, as the picture shows:

2. The **Auto Fill Options** button appears to give you some formatting options. In this case, you don’t need formatting options, so no action is required. The button disappears when you next make an entry in the cell.
Suggestions for practice

1. Create a formula for addition.
2. Create other formulas.
3. Add up a column of numbers.
4. Add up a row of numbers.

Online practice (requires Excel 2007)
Test 1, question 1

What do you type into an empty cell to start a formula? (Pick one answer.)

1. *
2. ( 
3. =
An equal sign (=) tells Excel that a calculation follows it.
What is a function? (Pick one answer.)

1. A prewritten formula.
2. A math operator.
A prewritten formula.

Functions are prewritten formulas, such as SUM, that save time.
A formula result is in cell C6. You wonder how you got the result. To see the formula, what do you do? (Pick one answer.)

1. Click in cell C6, and then press CTRL+SHIFT.

2. Click in cell C6, and then press F5.

3. Click in cell C6.
Click in cell C6.

It’s that simple. The formula is visible in the formula bar near the top of the worksheet whenever you click in cell C6. Or you can double-click cell C6 to see the formula in cell C6. Then press ENTER to see the formula result again in the cell.
Lesson 2

Use cell references
Use cell references

<table>
<thead>
<tr>
<th>Cell references</th>
<th>Refer to values in</th>
</tr>
</thead>
<tbody>
<tr>
<td>A10</td>
<td>the cell in column A and row 10</td>
</tr>
<tr>
<td>A10,A20</td>
<td>cell A10 and cell A20</td>
</tr>
<tr>
<td>A10:A20</td>
<td>the range of cells in column A and rows 10 through 20</td>
</tr>
<tr>
<td>B15:E15</td>
<td>the range of cells in row 15 and columns B through E</td>
</tr>
<tr>
<td>A10:E20</td>
<td>the range of cells in columns A through E and rows 10 through 20</td>
</tr>
</tbody>
</table>

Cell references identify individual cells or cell ranges in columns and rows.

Cell references tell Excel where to look for values to use in a formula.

Excel uses a reference style called A1, which refers to columns with letters and to rows with numbers. The numbers and letters are called row and column headings.

This lesson shows how Excel can automatically update the results of formulas that use cell references, and how cell references work when you copy formulas.
Suppose the 11.97 value in cell C4 was incorrect. A 3.99 video rental was left out.

Excel can automatically update totals to include changed values.

To add 3.99 to 11.97, you would click in cell C4, type the following formula into the cell, and then press ENTER:

\[ =11.97+3.99 \]
As the picture shows, when the value in cell C4 changes, Excel automatically updates the February total in cell C7 from 126.93 to 130.92.

Excel can do this because the original formula =SUM(C3:C6) in cell C7 contains cell references.

If you had entered 11.97 and other specific values into a formula in cell C7, Excel would not be able to update the total. You’d have to change 11.97 to 15.96 not only in cell C4, but in the formula in cell C7 as well.
Other ways to enter cell references

You can type cell references directly into cells, or you can enter cell references by clicking cells, which avoids typing errors.

In the first lesson you saw how to use the SUM function to add all the values in a column.

You could also use the SUM function to add just a few values in a column, by selecting the cell references to include.
Imagine that you want to know the combined cost for video rentals and CDs in February.

The example shows you how to enter a formula into cell C9 by clicking cells.

1. In cell C9, type the equal sign, type `SUM`, and type an opening parenthesis.
Imagine that you want to know the combined cost for video rentals and CDs in February.

The example shows you how to enter a formula into cell C9 by clicking cells.

3. Click cell C6. That cell reference appears in cell C9 following the comma. Type a closing parenthesis after it.

4. Press ENTER to display the formula result, 45.94.

A color marquee surrounds each cell as it is selected and disappears when you press ENTER to display the result.
The arguments C4 and C6 tell the SUM function what values to calculate with. The parentheses are required to separate the arguments from the function.

The comma, which is also required, separates the arguments.
Now that you’ve learned about using cell references, it’s time to talk about the different types.

The picture shows two types, **relative** and **absolute**.

1. **Relative references** automatically change as they’re copied down a column or across a row.

When the formula =C4*$D$9 is copied from row to row in the picture, the relative cell references change from C4 to C5 to C6.
Now that you’ve learned about using cell references, it’s time to talk about the different types.

The picture shows two types, **relative** and **absolute**.

**Absolute references** are fixed. They don’t change if you copy a formula from one cell to another. Absolute references have dollar signs ($) like this: $D$9.

As the picture shows, when the formula =C4*$D$9 is copied from row to row, the absolute cell reference remains as $D$9.
For example, $A1$ is an absolute reference to column A and a relative reference to row 1.

As a mixed reference is copied from one cell to another, the absolute reference stays the same but the relative reference changes.
Using an absolute cell reference

You use absolute cell references to refer to cells that you don’t want to change as the formula is copied.

References are relative by default, so you would have to type dollar signs, as shown by callout 2 in the picture, to change the reference type to absolute.
Say you receive some entertainment coupons offering a 7 percent discount for video rentals, movies, and CDs. How much could you save in a month by using the discounts?

You could use a formula to multiply those February expenses by 7 percent.

So start by typing the discount rate .07 in the empty cell D9, and then type the formula in cell D4.
Say you receive some entertainment coupons offering a 7 percent discount for video rentals, movies, and CDs. How much could you save in a month by using the discounts?

Then in cell D4, type \(=C4*\). Remember that this relative cell reference will change from row to row.

Enter a dollar sign (\$) and \(D\) to make an absolute reference to column D, and \$9\) to make an absolute reference to row 9. Your formula will multiply the value in cell C4 by the value in cell D9.
Say you receive some entertainment coupons offering a 7 percent discount for video rentals, movies, and CDs. How much could you save in a month by using the discounts?

Cell D9 contains the value for the 7 percent discount.

You can copy the formula from cell D4 to D5 by using the fill handle. As the formula is copied, the relative cell reference changes from C4 to C5, while the absolute reference to the discount in D9 does not change; it remains as $D$9 in each row it is copied to.
Suggestions for practice

1. Type cell references in a formula.
2. Select cell references for a formula.
3. Use an absolute reference in a formula.
4. Add up several results.
5. Change values and totals.

Online practice (requires Excel 2007)
How does an absolute cell reference work? (Pick one answer.)

1. The cell reference automatically changes when the formula is copied down a column or across a row.
2. The cell reference is fixed.
3. The cell reference uses the A1 reference style.
The cell reference is fixed.

Absolute cell references don’t change if you copy a formula from one cell to another.
Test 2, question 2

Which of these is an absolute reference? (Pick one answer.)

1. B4:B12
2. $A$1
$A$1

The dollar signs indicate an absolute reference to column A, row 1, which does not change when it's copied.
Test 2, question 3

If you copy the formula =C4*$D$9 from cell C4 to cell C5, what will the formula be in cell C5? (Pick one answer.)

1. =C5*$D$9
2. =C4*$D$9
3. =C5*$E$10
Test 2, question 3: Answer

=C5*$D$9

As the formula is copied, the relative cell reference, C4, changes to C5. The absolute cell reference, $D$9, does not change; it remains the same in each row it is copied to.
Lesson 3

Simplify formulas by using functions
# Simplify formulas by using functions

Function names express long formulas quickly.

As prewritten formulas, functions simplify the process of entering calculations.

<table>
<thead>
<tr>
<th>Function</th>
<th>Calculates</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVERAGE</td>
<td>an average</td>
</tr>
<tr>
<td>MAX</td>
<td>the largest number</td>
</tr>
<tr>
<td>MIN</td>
<td>the smallest number</td>
</tr>
</tbody>
</table>

Using functions, you can easily and quickly create formulas that might be difficult to build for yourself.

SUM is just one of the many Excel functions. In this lesson you’ll see how to speed up tasks with a few other easy ones.
Find an average

You can use the AVERAGE function to find the mean average cost of all entertainment for January and February.

Excel will enter the formula for you.

Click in cell D7, and then:

1. On the Home tab, in the Editing group, click the arrow on the Sum button, and then click Average in the list.

2. Press ENTER to display the result in cell D7.
Find the largest or smallest value

The MAX function finds the largest number in a range, and the MIN function finds the smallest number in a range.

The picture illustrates the use of MAX.

Start by clicking in cell F7. Then:

1. On the Home tab, in the Editing group, click the arrow on the Sum button, and then click Max in the list.

2. Press ENTER to display the result in cell F7. The largest value in the series is 131.95.
Find the largest or smallest value

The MAX function finds the largest number in a range, and the MIN function finds the smallest number in a range.

The picture illustrates the use of MAX.

To find the smallest value in the range, you would click **Min** in the list and press ENTER.

The smallest value in the series is 131.75.
You can print formulas and put them up on your bulletin board to remind you how to create them.

But first, you need to display the formulas on the worksheet.

Here's how:

1. Click the **Formulas** tab.
2. In the **Formula Auditing** group, click **Show Formulas**.
Print formulas

You can print formulas and put them up on your bulletin board to remind you how to create them.

But first, you need to display the formulas on the worksheet.

Here's how:

3. Click the **Microsoft Office Button** in the upper-left corner of the Excel window, and click **Print**.

**Tip**: You can also press CTRL+` to display and hide formulas.
What’s that funny thing in my worksheet?

Sometimes Excel can’t calculate a formula because the formula contains an error.

If that happens, you’ll see an error value in a cell instead of a result.

Here are three common error values:

- #### The column isn’t wide enough to display the contents of the cell. To fix the problem, you can increase column width, shrink the contents to fit the column, or apply a different number format.
What’s that funny thing in my worksheet?

Sometimes Excel can’t calculate a formula because the formula contains an error. If that happens, you’ll see an error value in a cell instead of a result.

Here are three common error values:

- **#REF!** A cell reference isn’t valid. Cells may have been deleted or pasted over.

- **#NAME?** You may have misspelled a function name or used a name that Excel doesn’t recognize.
Excel offers many other useful functions, such as date and time functions and functions you can use to manipulate text.

To see all the other functions:

1. Click the **Sum** button in the **Editing** group on the **Home** tab.
2. Click **More Functions** in the list.
3. In the **Insert Function** dialog box that opens, you can search for a function.
Find more functions

Excel offers many other useful functions, such as date and time functions and functions you can use to manipulate text.

In addition to searching for a function in this dialog box, you can select a category and then scroll through the list of functions in the category.

And you can click Help on this function at the bottom of the dialog box to find out more about any function.
Suggestions for practice

1. Find an average.
2. Find the largest number.
3. Find the smallest number.
4. Display and hide formulas.
5. Create and fix error values.
6. Create and fix the error value "#NAME?".

Online practice (requires Excel 2007)
How would you print formulas? (Pick one answer.)

1. Click the **Microsoft Office Button**, and then click **Print**.

2. Click **Normal** on the **View** tab at the top of the screen, click the **Microsoft Office Button**, and then click **Print**.

3. In the **Formula Auditing** group on the **Formulas** tab, click **Show Formulas**; then click the **Microsoft Office Button**, and click **Print**.
In the **Formula Auditing** group on the **Formulas** tab, click **Show Formulas**; then click the **Microsoft Office Button**, and click **Print**.

Clicking **Show Formulas** displays the formulas on your worksheet before you print.
Test 3, question 2

What does #### mean? (Pick one answer.)

1. The column is not wide enough to display the content of the cell.
2. The cell reference is not valid.
3. You have misspelled a function name or used a name that Excel doesn’t recognize.
Test 3, question 2: Answer

The column is not wide enough to display the content of the cell.

You can increase the column width to display the content.
What is the keyboard shortcut to display formulas on the worksheet? (Pick one answer.)

1. CTRL+`
2. CTRL+: 
3. CTRL+;
CTRL+`  

The ` is next to the 1 key on most keyboards. The keyboard shortcut displays and hides formulas.
Quick Reference Card

For a summary of the tasks covered in this course, view the Quick Reference Card.
JohnRouda.com presents:

Microsoft® Office Excel® 2007 Training

Learn how to figure out dates using formulas in Excel
Course contents

• Overview: It’s a date
• Lesson 1: What dates mean to Excel
• Lesson 2: Calculate dates by using formulas

Each lesson includes a list of suggested tasks and a set of test questions.
Overview: It’s a date

How many workdays until vacation? What’s the finish date for a project?

In this course, we’ll show you how to use formulas to find the number of days between dates.

You can calculate pretty much anything using these formulas — and we’ll even show you how to determine how many days old you are.
Course goals

- Use formulas to find the number of days between dates.
- Determine the date that falls after a number of workdays.
- Find a date that falls after a number of years, months, or days.
Lesson 1

What dates mean to Excel
What dates mean to Excel

There’s a difference between what dates mean to you and what they mean to Excel.

1. To you, 8/22/2010 is a month, day, and year.
2. To Excel, 8/22/2010 is serial number 40412.

In this lesson you’ll learn how Excel’s view of dates makes it possible to do date arithmetic, and how to enter dates in a format that Excel can understand.
The calendar starts in 1900

Dates are stored in Excel as serial numbers starting with 1, which represents January 1, 1900. That’s when the Excel calendar starts.

Each day after that adds one number to the sequence. For example, January 2, 1900 is stored as 2.

That means if you type 8/22/2010, Excel stores the date as 40412 — or 40411 days from January 1, 1900.
The calendar starts in 1900

Storing dates as serial numbers makes it possible for Excel to do date arithmetic.

To find the number of days between two dates, for example, Excel subtracts one serial number from another.
How Excel recognizes dates

Whether you type 8/22/2010, 22-Aug-2010, or even August 22, 2010, it’s all stored as serial number 40412.

The exception is if you use a format that Excel doesn’t recognize as a date.

For example, if you typed August-22,2010 or 8,22,10, Excel would store that information as plain text, not a serial number.
How Excel recognizes dates

Right-click a cell with a date in it, and choose **Format Cells**. Then you can:

1. Select **Date** in the **Category** list.
2. Select a date format in the **Type** list.
Suggestions for practice

1. Format a date as a serial number.
2. Format a serial number as a date.
3. Select different date formats.
4. Enter the current date.

Online practice (requires Excel 2007)
Test 1, question 1

Which of these dates will Excel store as plain text rather than as a serial number? (Pick one answer.)

1. June 23, 2012
2. 23-June-12
3. June 23 2012

Learn how to figure out dates using formulas in Excel
June 23 2012.

This date does not contain any formatting that Excel recognizes as a date.
Test 1, question 2

What would happen if you used a formula to do math with dates, but one of the dates was typed in a format that Excel does not recognize as a date? (Pick one answer.)

1. Excel would display a message telling you to reformat the date.
2. Excel would display an error value.
3. Excel would reformat the date into the correct format.
Excel would display an error value.

Excel would display #VALUE! instead of a formula result. In this case the error value means that a cell in the formula contains text instead of a date.
Test 1, question 3

8/22/2011 and 22-August-2011 are stored as different serial numbers. (Pick one answer.)

1. True.

2. False.
Test 1, question 3: Answer

False.

Same date, same number.
Lesson 2

Calculate dates by using formulas
In this lesson, you’ll learn how to use a simple formula to find the number of days between two dates, and you’ll see why it’s very important to type dates so that Excel can recognize them.

<table>
<thead>
<tr>
<th>Function</th>
<th>Used to find</th>
</tr>
</thead>
<tbody>
<tr>
<td>NETWORKDAYS</td>
<td>Net number of workdays between two dates</td>
</tr>
<tr>
<td>WORKDAY</td>
<td>Date that falls a specified number of workdays after another date</td>
</tr>
<tr>
<td>DATE</td>
<td>Date that falls a specified number of years, months, or days after another</td>
</tr>
<tr>
<td>TODAY</td>
<td>Current date</td>
</tr>
</tbody>
</table>

To do arithmetic in Excel, you use formulas.
Find the number of days between two dates

Imagine that today is June 9, 2010. Your vacation starts on Aug. 21, 2010. You want to find out how many days there are until vacation. Here’s how to do the math.

1. Type a simple formula into an empty cell: \( =A3-A2 \)

2. The result is that there are 73 days between the two dates.

3. The formula is visible in the formula bar near the top of the worksheet whenever you select the cell that contains the formula.
Find the number of workdays between two dates

Finding the number of workdays (Monday through Friday) between two dates can’t be done by simply subtracting one date from another.

It requires a prewritten formula called the NETWORKDAYS function, which calculates the net number of workdays between two dates.
It’s still June 9, 2010, and your vacation still starts on August 21, 2010, but now you want to find how many workdays until vacation.

1. Type the formula \( \text{=NETWORKDAYS(A2,A3)} \)

2. The result is that there are 53 workdays until vacation.

3. Once again, the formula is visible in the formula bar near the top of the worksheet whenever you select the cell that contains the formula.
Find the date after a number of workdays

Suppose you need to find a date, such as an invoice due date or project end date that occurs a number of workdays before or after a certain date. It’s easy using the WORKDAY function.

Imagine that you have approximately 80 workdays in which to complete a project that begins on 12/31/2010, and you need to find the project end date.

First you’d enter those values into cells A2 and A3 as shown. Next, you’d enter the dates of any holidays likely to affect the calculation, each holiday in its own cell.
Learn how to figure out dates using formulas in Excel

Find the date after a number of workdays

Suppose you need to find a date, such as an invoice due date or project end date that occurs a number of workdays before or after a certain date. It’s easy using the WORKDAY function.

1. Then you would type the formula into an empty cell:
   \[ \text{=WORKDAY(A2,A3,A4:A6)} \]

2. …and find that the project must be completed by 4/22/2011.
Find the date after a number of months

Say that you have about 25 months from 6/9/2011 to complete a project, and you need to find the project end date.

You could do that by using the DATE function.

The DATE function has three arguments: year, month, and day.

Learn how to figure out dates using formulas in Excel
Find the date after a number of months

1. Type this formula in cell A4: \( \text{=DATE}(2011,6+B2,9) \)

2. The project ends on 7/9/2013.

3. The formula is shown in the formula bar.

In this example, you’d start by entering 25 in cell B2.
Find the date after a number of years, months, days

Imagine that you’ve been given an estimate of 1 year and 7 and a half months (15 days) to finish a project, and you need to find the project end date.

You can use the DATE formula once again.

Learn how to figure out dates using formulas in Excel
Find the date after a number of years, months, days

1. Then type this formula into cell A6: 

2. The result shows that the project ends on January 24, 2013.

3. The formula is shown in the formula bar.

Learn how to figure out dates using formulas in Excel
Using the TODAY function

The TODAY function is unusual; it’s one of the few Excel functions that doesn’t require any argument, although it does require opening and closing parentheses: =TODAY()

TODAY inserts the current date, which is updated each time a workbook is opened or recalculated.

You can use it to find out things like how many days old you are, based on today’s date.
Suggestions for practice

1. Find the total number of days between two dates.
2. Find the number of workdays between two dates.
3. Find the date after a number of workdays.
4. Find the number of workdays before a date.
5. Find the date after a number of months.
6. Find the date after a number of years, months, and days.
7. Update formula results.
8. Find out how many days old you are today.

Online practice (requires Excel 2007)
Test 2, question 1

Which function would you use to find the date that falls after a number of workdays? (Pick one answer.)

1. NETWORKDAYS
2. WORKDAY
3. TODAY
Use WORKDAY to find a date, such as a due date or end date, that is a number of workdays before or after a date.
Test 2, question 2

What do you type to start a formula in Excel? (Pick one answer.)

1. A function.

2. Mathematical operators.

3. An equal sign (=).
Test 2, question 2: Answer

An equal sign (=).

Every formula begins with an equal sign. If a formula does not produce results, check to see if there’s an equal sign at the beginning.
Test 2, question 3

How many arguments does the DATE function have? (Pick one answer.)

1. One.
2. Two.
3. Three.
Three.

The arguments are year, month, and day.
For a summary of the tasks covered in this course, view the Quick Reference Card.
JohnRouda.com presents:

Microsoft® Office Excel® 2007 Training

Get up to speed
Course contents

• Overview: A hands-on introduction
• Lesson 1: What’s changed, and why
• Lesson 2: Get to work in Excel
• Lesson 3: A new file format

The first two lessons include a list of suggested tasks, and all include a set of test questions.
Excel 2007 has a new look! It’s got the familiar worksheets you’re accustomed to, but with some changes.

Notably, the old look of menus and buttons at the top of the window has been replaced with the Ribbon.

This course shows you how to use the Ribbon and highlights the other changes in Excel that will help you make better worksheets, faster.
Course goals

• Get a handle on the new look of Excel.

• Find everyday commands on the Ribbon: Cut, Copy, Paste, Insert Sheet Rows, Insert Sheet Columns, and Sum.

• Save workbooks in the new Excel file formats.
Lesson 1
What’s changed, and why
What’s changed, and why

Yes, there’s a lot of change in Excel 2007. It’s most noticeable at the top of the window.

But it’s good change.

The commands you need are now more clearly visible and more readily available in one control center called the Ribbon.
What’s on the Ribbon?

The three parts of the Ribbon are tabs, groups, and commands.

1. **Tabs**: Tabs represent core tasks you do in Excel. There are seven tabs across the top of the Excel window.

2. **Groups**: Groups are sets of related commands, displayed on tabs.

3. **Commands**: A command is a button, a menu, or a box where you enter information.

Get up to speed
What’s on the Ribbon?

How do you get started on the Ribbon?

Begin at the beginning.

The principal commands in Excel are gathered on the first tab, the **Home** tab.
What’s on the Ribbon?

Groups pull together all the commands you’re likely to need for a particular type of task.

Throughout your task, groups remain on display and readily available; commands are no longer hidden in menus.

Instead, vital commands are visible above your work space.
More commands, but only when you need them

The commands on the Ribbon are the ones you use the most.

Instead of showing every command all the time, Excel 2007 shows some commands only when you may need them, in response to an action you take.

So don’t worry if you don’t see all the commands you need at all times. Take the first steps, and the commands you need will be at hand.
More options, if you need them

Sometimes an arrow, called the **Dialog Box Launcher**, appears in the lower-right corner of a group.

This means more options are available for the group.

Click the Dialog Box Launcher button, and you'll see a dialog box or task pane. The picture shows an example:

1. On the **Home** tab, click the arrow button in the **Font** group.
2. The **Format Cells** dialog box opens, with superscript and other options related to fonts.
Put commands on your own toolbar

Do you often use commands that aren’t as quickly available as you’d like?

You can easily add them to the Quick Access Toolbar.

Animation: Right-click, and click Play.

Play the animation to see the process of adding a button to the toolbar and then removing a button from the toolbar.
Put commands on your own toolbar

Do you often use commands that aren’t as quickly available as you’d like?

You can easily add them to the Quick Access Toolbar.

The Quick Access Toolbar is above the Ribbon when you first start Excel 2007. There, commands are always visible and near at hand.
What about favorite keyboard shortcuts?

If you rely on the keyboard more than the mouse, you’ll want to know that the Ribbon design comes with new shortcuts.

This change brings two big advantages over previous versions of Excel:

• There are shortcuts for every single button on the Ribbon.

• Shortcuts often require fewer keys.
What about favorite keyboard shortcuts?

The new shortcuts also have a new name: **Key Tips**.

You press ALT to make Key Tips appear.

For example, here’s how to use Key Tips to center text:

1. Press ALT to make the Key Tips appear.
2. Press H to select the **Home** tab.
3. Press A, then C to center the selected text.
What about favorite keyboard shortcuts?

What about the old keyboard shortcuts?

Keyboard shortcuts of old that begin with CTRL are still intact, and you can use them the same way you always have.

For example, the shortcut CTRL+C still copies something to the clipboard, and the shortcut CTRL+V still pastes something from the clipboard.
Not only the Ribbon is new in Excel 2007.

Page Layout view is new, too.

If you’ve worked in Print Layout view in Microsoft Office Word, you’ll be glad to see Excel with similar advantages.
Here’s what you’ll see in the worksheet:

1. Column headings.
2. Row headings.

To see the new view, click **Page Layout View** on the **View** toolbar.
A new view

In Page Layout view there are page margins at the top, sides, and bottom of the worksheet, and a bit of blue space between worksheets.

Rulers at the top and side help you adjust margins.

Other benefits of the new view:

• You don’t need to use Print Preview to find problems before you print.
• It’s easier than ever to add headers and footers.
• You can see different worksheets in different views.
Working with different screen resolutions

Everything described so far applies if your screen is set to high resolution and the Excel window is maximized.

If not, things look different.

When and how do things look different?

- **At low resolution.** If your screen is set to a low resolution, for example to 800 by 600 pixels, a few groups on the Ribbon will display the group name only, not the commands in the group.
Working with different screen resolutions

Everything described so far applies if your screen is set to high resolution and the Excel window is maximized.

If not, things look different.

When and how do things look different?

- **When the Excel window isn’t maximized.** Some groups will display only the group name.

- **With Tablet PCs.** On those with smaller screens, the Ribbon adjusts to show smaller versions of tabs and groups.
Suggestions for practice

1. Enter text.
2. Adjust column width.
3. Change document views.
4. Show or hide white space.
5. Add a button to the Quick Access Toolbar.

Online practice (requires Excel 2007)
Test 1, question 1

You can customize Excel 2007 by adding commands to the Quick Access Toolbar. (Pick one answer.)

1. True.

2. False.

Get up to speed
True.

You can add the commands you want to be at your fingertips to the Quick Access Toolbar.
Test 1, question 2

Some commands appear only when you need them. (Pick one answer.)

1. True.

2. False.
Take the first step or two, and a new tab will appear, with all the commands you need. For example, insert a chart, or a header and footer, and you’ll see more commands.
Lesson 2

Get to work in Excel
Get to work in Excel

The first lesson helped you get oriented to the new look of Excel 2007.

Now it’s time to get to work.

Say you’ve got a half hour before your next meeting to make some revisions to a worksheet that you created in a previous version of Excel.

Can you do the basic things you need to do in Excel 2007, in just 30 minutes? This lesson will show you how.
Open your file

First things first. You want to open an existing workbook created in an earlier version of Excel.

Do the following:

1. Click the **Microsoft Office Button**.
2. Click **Open**, and select the workbook you want.
3. Also note that you can click **Excel Options**, at the bottom of the menu, to set program options.
Now you want to add a column to your worksheet to identify product categories.

You want it to go between two existing columns of data.

Animation: Right-click, and click Play.

View the animation to see the process of inserting a column into the worksheet.
Now you want to add a column to your worksheet to identify product categories.

It should go between two existing columns of data, **Quantity** and **Supplier**.

Your worksheet contains rows of products ordered from various suppliers, and you want to add the new column to identify the various products as dairy, grains, produce, and so on.
Insert a column

Follow this procedure to add the column between the **Quantity** column and the **Supplier** column:

1. Click in the **Supplier** column. Then on the **Home** tab, in the **Cells** group, click the arrow on **Insert**.

2. On the menu that appears, click **Insert Sheet Columns**. A new blank column is inserted, and you enter the new data in the column.

3. If you need to adjust the column width to fit the data, in the **Cells** group, click the arrow on **Format**. In the list that appears, click **AutoFit Column Width**.
Format and edit data

You format and edit data by using commands in groups on the **Home** tab.

For example, the column titles will stand out better if they are in bold type.

To make it so, select the row with the titles and then on the **Home** tab, in the **Font** group, click **Bold**.
While the titles are still selected, you decide to change their color and their size, to make them stand out even more.

In the **Font** group, click the arrow on **Font Color**. You’ll see many more colors to choose from than before.

You can also see how the title will look in different colors by pointing at any color and waiting a moment.
Format and edit data

You can use the Font group to take care of other formatting and editing options, too.

• To increase the font size, click Increase Font Size.

• While the titles are still selected, you decide to center them in the cells. In the Alignment group, click Center.

• Finally, you find that you need to enter one more order for Louisiana Fiery Hot Pepper Sauce. Select that product name, and in the Clipboard group, click Copy. Then click in the bottom row, and in the Clipboard group again, click Paste.
Before handing off your report, you want to add up the numbers in the Quantity column.

It’s easy: Use the **Sum** button .

1. Place the cursor in the last cell in the Quantity column, and then click the **Sum** button on the **Home** tab. (It’s in the **Editing** group.)

2. Press ENTER to see the formula result.
Add headers and footers

As a finishing touch, you decide to add headers and footers to the worksheet.
This will help make clear to everyone what the data is about.

Here’s what to do:

1. Switch to Page Layout view. You can click the **View** tab, and then click **Page Layout View** in the **Workbook Views** group. Or click the middle button on the **View** toolbar at the bottom of the window.
As a finishing touch, you decide to add headers and footers to the worksheet. This will help make clear to everyone what the data is about.

Here’s what to do:

2. Click in the area at the top of the page that says **Click to add header**.

3. As soon as you do, the **Header & Footer Tools** and the **Design** tab appear at the top of the Ribbon.
It’s time to print the report.

In Page Layout view, you can make adjustments and see the changes on the screen before you print.

Here’s how to use Page Layout view:

1. Click the **Page Layout** tab.

2. In the **Page Setup** group, click **Orientation** and then select **Portrait** or **Landscape**. In Page Layout view, you’ll see the orientation change, and how your data will look each way.
It’s time to print the report.

In Page Layout view, you can make adjustments and see the changes on the screen before you print.

Here’s how to use Page Layout view:

3. Still in the **Page Setup** group, click **Size** to choose paper size. You’ll see the results of your choices as you make them. (What you see is what you print.)
The New Workbook window offers the perfect place to start in Excel.

When you click the Microsoft Office Button and then click New, the New Workbook window opens.

At the top of the window, you can select either a new blank workbook or a template.
Suggestions for practice

1. Insert a column.
2. Use AutoSum.
3. Add a header and a footer.
4. Add a few finishing touches.
5. Explore print options.

Online practice (requires Excel 2007)
To insert a new column, you use the commands in the Cells group on the Home tab. (Pick one answer.)

1. True.

2. False.
Test 2, question 1: Answer

True.

Then click the arrow next to **Insert**, and then click **Insert Sheet Columns**.
Test 2, question 2

Where is the button that you click to find commands to open and close your files? (Pick one answer.)

1. On the first tab.
2. In the upper-left corner of the window.
3. Underneath the Ribbon.
Test 2, question 2: Answer

In the upper-left corner of the window.

Click the big round Microsoft Office Button in the upper-left corner.
In Page Layout view, you want to add a header to your worksheet, but you don’t see the commands you need. To get the commands, you need to click in the area that says “Click to add header.” (Pick one answer.)

1. True.

2. False.
Test 2, question 3: Answer

True.

As soon as you do, the **Header & Footer Tools** and the **Design** tab appear on the Ribbon. These have all the commands to work with headers and footers.
Lesson 3

A new file format
A new file format

Excel has a new file format.

But you can still open and edit older workbooks and share files with people who don’t have Excel 2007.

The new file format brings increased security for your files, reduced risk of file corruption, reduced file size, and new features.
In Excel 2007, you can open files created in Excel 95 through Excel 2003.

But what if you’re the first person in your office to have Excel 2007? What if you need to share files with departments that don’t have Excel 2007 yet?

Don’t panic. You can all share workbooks with each other.
Working with files from earlier versions

Here’s how:

• Old files stay old unless you choose otherwise.
  – Excel will save an older file in its original format unless you specify otherwise. For example, if it started in Excel 2003, Excel 2007 saves it in 2003 format by default.

• Newer features warn you if you save a file as older.
  – When you save a file in a previous version’s format, and the 2007 features you used are not compatible with the previous version, a Compatibility Checker tells you so.
Working with files from earlier versions

Here’s how:

• You can always copy newer files in newer format first.
  – Just tell Excel you want an Excel Workbook (*.xlsx). That copy of the file will contain all the Excel 2007 features.

• You can share documents between versions by using a converter.
  – Colleagues with Excel 2000 through 2003 can open 2007 files by downloading and using a converter.
Benefits of the new format

The new file format means improvements to Excel.

Here are its chief benefits:

- New features
- Safer files
- Less risk of file corruption
Benefits of the new format

The new file format means improvements to Excel.

Here are its chief benefits:

- Reduced file size
- More useful data
New file formats, new options when you save

When you save a file in Excel 2007, you can choose from several file types.

- **Excel Workbook (*.xlsx)**. Use when there are no macros or VBA code.
- **Excel Macro-Enabled Workbook (*.xlsm)**. Use when there are macros or VBA code.
- **Excel Template (*.xltx)**. Use when you need a template.
New file formats, new options when you save

When you save a file in Excel 2007, you can choose from several file types.

- **Excel Macro-Enabled Template ( *.xltm ).** Use when you need a template and the workbook contains macros or VBA.

- **Excel Binary Workbook ( *.xlsb ).** Use with an especially large workbook.
New file formats, new options when you save

When you save a file in Excel 2007, you can choose from several file types.

- **Excel 97-Excel 2003 Workbook (*.xls)**. Use when you need to share with someone working in a previous version of Excel.

- **Microsoft Excel 5.0/95 Workbook (*.xls)**. Use when you need to share with someone using Microsoft Excel 5.0.
If you save a file that was created in a previous version of Excel as an Excel 2007 file, the file can use all the new Excel features. (Pick one answer.)

1. True.

2. False.
Test 3, question 1: Answer

True.
Why was the Excel 2007 file format changed to XML? (Pick one answer.)

1. New features could be added to Excel.
2. Files are safer.
3. Less risk of file corruption.
4. Reduced file size.
5. All of the above.
Test 3, question 2: Answer

All of the above.
Test 3, question 3

Someone sends you an Excel 2003 file, which you open in Excel 2007. When you’re finished working with it in 2007, the file will automatically be saved as Excel 2007, unless you change the option. (Pick one answer.)

1. True.

2. False.
False.

If it started in Excel 2003, Excel 2007 saves it in the 2003 format unless you say otherwise.
Quick Reference Card

For a summary of the tasks covered in this course, view the Quick Reference Card.
Course contents

• Overview: Make sense out of data
• Lesson: Make your data work for you

The lesson includes a list of suggested tasks and a set of test questions.
Overview: Make sense out of data

Your worksheet has lots of data, but do you know what those numbers mean? Does the data answer your questions?

PivotTable reports offer a fast and powerful way to analyze numerical data, look at the same data in different ways, and answer questions about it.

In this short course you’ll learn how PivotTable reports work and find out how to create one in Excel 2007.
Course goal

• Use a PivotTable report to analyze and summarize your data.
Lesson

Make your data work for you
Imagine an Excel worksheet of sales figures. It lays out thousands of rows of data about salespeople in two countries along with how much they sold on individual days.

It’s a lot of data to deal with—listed in row after row and divided into multiple columns. How can you get information out of the worksheet and make sense out of all of the data?

Use PivotTable reports. They turn the data into small, concise reports that tell you exactly what you need to know.
Review your source data

Before you start to work with a PivotTable report, take a look at your Excel worksheet to make sure it’s well prepared for the report.

When you create a PivotTable report, each column of source data becomes a field that you can use in the report.

Fields summarize multiple rows of information from the source data.
Review your source data

The names of the fields for the report come from the column titles in your source data. So be sure you have names for each column across the first row of the worksheet in the source data.

The remaining rows below the headings should contain similar items in the same column.

For example, text should be in one column, numbers in another column, and dates in another column. In other words, a column that contains numbers should not contain text, and so on.
Finally, there should be no empty columns within the data that you’re using for the PivotTable report.

It’s also best if there are no empty rows.

For example, blank rows that are used to separate one block of data from another should be removed.
Here’s how to get started with a PivotTable report.

You use the **Create PivotTable** dialog box, shown here.

1. When the data is ready, click anywhere in the data.

2. On the **Insert** tab, in the **Tables** group, click **PivotTable**, and then click **PivotTable** again. The **Create PivotTable** dialog box opens.
Here’s how to get started with a PivotTable report.

You use the **Create PivotTable** dialog box, shown here.

3. The **Select a table or range** option is already selected for you. The **Table/Range** box shows the range of the selected data, which you can change if you want.

4. Click **OK**.
PivotTable report basics

This is what you see in the new worksheet after you close the Create PivotTable dialog box.

1. On one side is the **layout area** ready for the PivotTable report.

2. On the other side is the **PivotTable Field List**. This list shows the column titles from the source data. As mentioned earlier, each title is a **field**: Country, Salesperson, and so on.
PivotTable report basics

You create the PivotTable report by moving any of the fields shown in the PivotTable Field List to the layout area.

To do this, either select the check box next to the field name, or right-click a field name and then select a location to move the field to.
Now you’re ready to build the PivotTable report. The fields you select for the report depend on what you want to know.

To start: How much has each person sold?

Animation: Right-click, and click Play.

To get this answer, you need data about the salespeople and their sales numbers. So in the PivotTable Field List, select the check boxes next to the Salesperson and Order Amount fields. Excel then places each field in a default area of the layout.
Now you’re ready to build the PivotTable report. The fields you select for the report depend on what you want to know.

To start: How much has each person sold?

To get the answer, you need data about the salespeople and their sales numbers.

So in the **PivotTable Field List**, you’ll select the check boxes next to the **Salesperson** and **Order Amount** fields. Excel then places each field in a default area of the layout.
Build a PivotTable report

The data in the **Salesperson** field (the salespeople’s names), which doesn’t contain numbers, is displayed as rows on the left side of the report.

The data in the **Order Amount** field, which does contain numbers, correctly shows up in an area to the right.

Get started with PivotTable reports
Build a PivotTable report

It doesn’t matter whether you select the check box next to the Salesperson field before or after the Order Amount field. Excel automatically puts them in the right place every time.

Fields without numbers will land on the left, and fields with numbers will land on the right, regardless of the order in which you select them.
Build a PivotTable report

That’s it. With just two mouse clicks, you can see at a glance how much each salesperson sold.

And here are a couple of parting tips on the topic.

First, it’s fine to stop with just one or two questions answered; the report doesn’t have to be complex to be useful. PivotTable reports can offer a fast way to get a simple answer.

Next, don’t worry about building a report incorrectly. Excel makes it easy to try things out and see how data looks in different areas of the report.
Now you know how much each salesperson sold. But the source data lays out data about salespeople in two countries, Canada and the United States.

So another question you might ask is: What are the sales amounts for each salesperson by country?

To get the answer, you can add the **Country** field to the PivotTable report as a **report filter**. You use a report filter to focus on a subset of data in the report, often a product line, a time span, or a geographic region.
See sales by country

By using the **Country** field as a report filter, you can see a separate report for Canada or the United States, or you can see sales for both countries together.

Animation: Right-click, and click **Play**.

The animation shows how to add the **Country** field as a report filter. Right-click the **Country** field in the **PivotTable Field List**, click **Add to Report Filter**, and take it from there.
See sales by country

By using the **Country** field as a report filter, you can see a separate report for Canada or the United States, or you can see sales for both countries together.

To do this, right-click the **Country** field in the **PivotTable Field List**, click **Add to Report Filter**, and then take it from there.
See sales by date

The original source data has a column of Order Date information, so there is an **Order Date** field on the **PivotTable Field List**.

Animation: Right-click, and click **Play**.

This means you can find the sales by date for each salesperson.

View the animation to see how you can add the **Order Date** field to your report and then group the date data to create a more manageable view.
See sales by date

The original source data has a column of Order Date information, so there is an **Order Date** field on the **PivotTable Field List**.

This means you can find the sales by date for each salesperson.

To find out, you’ll add the **Order Date** field to your report and then use the **Grouping** dialog box to group the date data and create a more manageable view.
Pivot the report

Though the PivotTable report has answered your questions, it takes a little work to read the entire report—you have to scroll down the page to see all the data.

Animation: Right-click, and click **Play**.

So you can **pivot** the report to get a different view that’s easier to read.

When you pivot a report, you transpose the vertical or horizontal view of a field, moving rows to the column area or moving columns to the row area. It’s easy to do.
Pivot the report

Though the PivotTable report has answered your questions, it takes a little work to read the entire report—you have to scroll down the page to see all the data.

So you can pivot the report to get a different view that’s easier to read.

When you pivot a report, you transpose the vertical or horizontal view of a field, moving rows to the column area or moving columns to the row area. It’s easy to do.
If you prefer to build a PivotTable report by using the drag-and-drop method, as you could in previous versions of Excel, there’s still a way to do that.

There are four boxes at the bottom of the PivotTable Field List, called Report Filter, Row Labels, Column Labels, and Values.

As the animation shows, you can drag fields to these boxes to create your report.
Where did drag-and-drop go?

If you prefer to build a PivotTable report by using the drag-and-drop method, as you could in previous versions of Excel, there’s still a way to do that.

There are four boxes at the bottom of the **PivotTable Field List**: **Report Filter**, **Row Labels**, **Column Labels**, and **Values**. You can drag fields to these boxes to designate how the fields are used in the report.

The picture shows how you can drag the **Order Amount** field from the **Column Labels** to the **Values** box to add that field to the Values area of the report.
Suggestions for practice

1. Create the PivotTable report layout area.
2. Create a PivotTable report.
3. Change a heading name.
4. Sort the report.
5. Add a field to the report.
6. Add a report filter.
7. Pivot the report.
8. Add currency formatting to the report.

Online practice (requires Excel 2007)
Test question 1

After you build a PivotTable report, you can’t change the layout. (Pick one answer.)

1. True.

2. False.
Test question 1: Answer

False.

You can make changes as you go, or just start over.
Test question 2

What are PivotTable fields? (Pick one answer.)

1. Columns from the source data.
2. The area where you pivot data.
3. The PivotTable report layout area.
Test question 2: Answer

Columns from the source data.

Column headings from the source data become the names of the fields that you can use to build the PivotTable report. Each field summarizes multiple rows of information from the source data.
Test question 3

In the PivotTable Field List, you can tell which fields are already displayed on the report. (Pick one answer.)

1. True.
2. False.
Test question 3: Answer

True.

Fields used on the report have a check mark beside them, and the names are in bold type.
Quick Reference Card

For a summary of the tasks covered in this course, view the Quick Reference Card.